zoomit

توسعه‌دهندگان در حال ساخت ابزاری برای اجرای macOS Ventura روی مک‌های قدیمی هستند

توسعه‌دهندگان در حال ساخت ابزاری برای اجرای macOS Ventura روی مک‌های قدیمی هستند

اپل هنگام معرفی macOS Ventura در رویداد WWDC 2022 اعلام کرد که چندین مدل قدیمی مک از این سیستم‌عامل پشتیبانی نخواهند کرد که ازجمله می‌توان به مک‌ پرو Trash Can محبوب و اولین نسل مک‌بوک پرو با نوار لمسی اشاره کرد. بااین‌حال، گروهی از توسعه‌دهندگان تلاش می‌کنند ابزاری تولید دهند که به کاربران اجازه می‌دهد این سیستم‌عامل را روی مک‌های پشتیبانی‌نشده نیز اجرا کنند.

OpenCore Legacy Patcher که به‌اختصار با نام OCLP نیز شناخته می‌شود، ابزاری است که به مک‌های قدیمی اجازه می‌دهد macOS Big Sur و Monterey را بدون پشتیبانی رسمی اپل اجرا کنند. این ابزار براساس همان بوت‌لودر OpenCore توسعه یافته که از آن در Hackintosh نیز استفاده شده است.

به‌گزارش ۹to5Mac، توسعه‌دهندگان OCLP اعلام کرده‌اند که پشتیبانی از macOS Ventura آسان نخواهد بود؛ اما این تیم تا همین‌حالا، پیشرفت‌های مهمی در این مسیر به‌دست آورده است و صاحبان برخی مدل‌های قدیمی‌مک می‌توانند با بهره‌گرفتن از ابزار آن‌ها سیستم خود را مدت طولانی‌تری به‌روز نگه دارند. گفتنی است که چنین ابزارهایی از سال‌ها قبل و حتی از زمان پاور پی‌سی، وجود داشته است.

روش کارکرد ابزار OCLP و مشکلات پیش‌ روی اجرای macOS Ventura روی مک‌های قدیمی چیست؟ موضوع این است که در گذشته، یعنی وقتی اپل امکان اجرای نسخه‌های جدید macOS را روی برخی از مدل‌های خاص مک متوقف کرد، آن نسخه‌ها معمولاً هنوز روی مک‌هایی دیگری اجرا می‌شد که از پردازنده‌ای مشابه مک‌های ناسازگار بهره می‌برند. به‌عنوان مثال، macOS Monterey پشتیبانی از اکثر مک‌های عرضه‌شده بین سال‌های ۲۰۱۲ تا ۲۰۱۴ را پایان داد که از پردازنده‌های نسل سوم و چهارم اینتل استفاده می‌کنند.

بااین‌حال، این سیستم‌عامل همچنان رسماً روی Mac Pro 2013 و Mac mini 2014 اجرا می‌شود؛ دستگاه‌هایی که به تراشه‌های قدیمی اینتل مجهز هستند. این امر باعث می‌شود توسعه‌دهندگان بتوانند سیستم‌عامل دسکتاپ اپل را برای اجرا در مک‌هایی تغییر دهند که این شرکت دیگر از آن‌ها پشتیبانی نمی‌کنند.

چه چیزی با macOS Ventura تغییر می‌کند؟

درباره‌ی macOS Ventura دیگر هیچ‌یک از مک‌های مجهز به تراشه‌های قدیمی‌تر از نسل هفتم اینتل از این سیستم‌عامل پشتیبانی نمی‌کنند؛ به‌همین‌دلیل، اپل بیشتر درایورهای استفاده‌شده در این مدل‌های قدیمی را حذف کرده است. این موضوع شامل درایورهای پدهای لمسی، کنترلرهای اترنت اینتل، پردازنده‌های گرافیکی انویدیا و… می‌شود.

جدیدترین نسخه‌ی macOS که هنوز دردسترس عموم نیز قرار نگرفته است، به پردازنده‌هایی با مجموعه دستورالعمل‌ AVX2 و نسخه‌ی جدیدی از متال (Metal) نیاز دارد که با تراشه‌های گرافیکی قدیمی کار نمی‌کند؛ بااین‌حال، توسعه‌دهندگان OCLP پیشرفت‌هایی در این‌ زمینه کرده‌اند. این تیم به‌لطف فایل‌های سیستمی قدیمی که هنوز بخشی از فناوری Rosetta 2 محسوب می‌شود، موفق شدند macOS Ventura را بدون پشتیبانی از دستورالعمل AVX2 اجرا کنند که ویژگی پردازنده‌ی قدیمی را برای اجرای برنامه‌های اینتل روی مک‌های مجهز به تراشه‌های اختصاصی اپل شبیه‌سازی می‌کند. برخی از درایورهای قدیمی نیز برای اجرا روی macOS 13 پورت شده‌اند.

مقاله‌ی مرتبط:

  • مک و دستگاه‌های iOS خود را برای رفع مشکلات امنیتی مهم، سریعاً به‌روزرسانی کنید
  • Parallels Desktop 18 نصب ویندوز ۱۱ را در مک‌های مجهز به تراشه‌های اینتل آسان می‌کند

توسعه‌دهنده‌ای به‌ نام میکولا گریمالیوک نشان داد که macOS Ventura روی مک مینی ۲۰۱۴، مک مینی ۲۰۱۲، مک پرو ۲۰۰۸ و آی‌مک ۲۰۱۴ اجرا می‌شود. هنوز کارهای زیادی وجود دارد که باید انجام شود؛ اما تیم OCLP معتقد است که دارندگان برخی مک‌های قدیمی این فرصت را خواهند داشت تا جدیدترین نسخه‌ی این سیستم‌عامل را بدون مشکل خاصی اجرا کنند. مطمئناً راهکار تیم OCLP در مرحله‌ی کنونی ایدئال نیست؛ اما این‌که هنوز‌هم می‌توان از سیستم‌عامل‌های جدید روی کامپیوترهای یک‌ دهه قبل استفاده کرد، بسیار جالب به‌نظر می‌رسد.

مجله خبری نیوزلن

مشاهده بیشتر

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.

دکمه بازگشت به بالا